52攻略

首页 > 最新文章 / 正文

股价背离趋势公式 买入区抓机会

Weave 2020-09-09 最新文章
股票公式源码

BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

MM:=(BIAS1W 2*BIAS2W 3*BIAS3W)/6;

MN:=MA(MM,3);

GUP24:=LLV(LOW,36);

GUP25:=HHV(HIGH,30);

GUP26:=EMA((CLOSE-GUP24)/(GUP25-GUP24)*4,4)*25;

底背离:IF(MN<-4  ,17,0),COLORA67D3D,LINETHICK3;

顶背离: IF((GUP26>90),17,0), COLOR6B238E,LINETHICK3;

IF(MN<-4  ,12,0),colorblack,LINETHICK3;

IF((GUP26>90),12,0), colorblack,LINETHICK3;

DRAWTEXT(底背离,6,'底背离'),COLORA67D3D;

DRAWTEXT(顶背离,6,'顶背离'),colorgreen;

N:=20;

MID:=MA(C,N);

GUPT1:=POW((C-MID),2);

GUPT2:=MA(GUPT1,N);

GUPT3:=SQRT(GUPT2);

UPPER:=MID 2*GUPT3;

LOWER:=MID-2*GUPT3;

BOLL:=REF(MID,1);

UB:=REF(UPPER,1);

LB:=REF(LOWER,1);

LOWER1:=MID-GUPT3;

LB1:=REF(LOWER1,1);

股价线:(C-LB1)/(UB-LB)*100,colorgreen, LINETHICK1;

趋势线:MA(股价线,6),colorred, LINETHICK3;

90,colorgreen, LINETHICK1;

50,colorwhite, LINETHICK1;

0,colorwhite, LINETHICK1;

GUPC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);

准备买入:EMA(IF(L<= LLV(L,30),GUPC,0),3),COLORFF00FF,LINETHICK2;

GUPO5:=LLV(LOW,27);

GUPO6:=HHV(HIGH,34);

GUPO7:=EMA((CLOSE-GUPO5)/(GUPO6-GUPO5)*4,4)*25;

买入区: IF((GUPO7<10),80,100) ,COLORFFFF00,LINETHICK3;

IF((GUPO7<10),85,100) ,colorblack,LINETHICK2;

下单: IF(CROSS(3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),10),38,0),STICK ,coloryellow, LINETHICK4;

DRAWTEXT(下单,38,'下单!'),colorgreen;

BIAS1:=(C-MA(C,6))/MA(C,6)*100;

BIAS2:=(C-MA(C,12))/MA(C,12)*100;

BIAS3:=(C-MA(C,24))/MA(C,24)*100;

BIAS:=(BIAS1 2*BIAS2 3*BIAS3)/6;

乖离率1:=MA(BIAS,3);

乖离率:IF(CROSS(BIAS,乖离率1) AND 乖离率1<-9,28,0),colorred,LINETHICK2;

IF(CROSS(BIAS,乖离率1) AND 乖离率1<-9,18,0),colorred,LINETHICK2;

STICKLINE(CROSS(BIAS,乖离率1) AND 乖离率1<-9,-12,0,6,0),coloryellow;

DRAWTEXT(乖离率,18,'低买'),colorred;

TRJ:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);

神偷线:=(((DMP ) * 100) / TRJ);

辅助线:=((DMM * 100) / TRJ);

动向线:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 神偷线)) * 100),3));

ADXR:=((动向线 REF(动向线,3)) / 2);

图片示例

注意事项

安装出错解决方法:请在微信电脑客户端、微信网页版、手机微信里打开本公众号,然后直接复制代码到软件里。请不要用微信聊天的方式发送复制的代码,可能会出错导致无法使用。


本公众号所有指标公式仅供学习交流,请勿用于股票交易。

股市有风险,风险请自担,入市需谨慎。

·END·
 

股旁网

好公式 只为你

Tags:

留言与评论(共有 0 条评论)
   
验证码:
搜索
网站分类
标签列表